Redis - Service Status

AWS services issue

Incident Report for Redis

Resolved

We'd like to let you know that AWS has confirmed full resolution of the DNS issue affecting services in the US-EAST-1 region. All Redis Cloud environments are operating as expected.

If you have any questions or concerns, please do not hesitate to contact Redis support.
Posted Oct 21, 2025 - 00:00 UTC

Update

We continue to monitor the recovery of AWS services in the US-EAST-1 region. Our teams remain fully engaged and are tracking the event closely. If you have any questions or need assistance, please contact Redis Support.
Posted Oct 20, 2025 - 18:43 UTC

Update

AWS services in the US-EAST-1 cloud region are now in a recovering state following an identified issue with their DNS services. We continue to monitor closely until AWS confirms full resolution.
Posted Oct 20, 2025 - 11:41 UTC

Monitoring

We are aware of an ongoing issue impacting AWS services in the US-EAST-1 region. Some Redis Cloud customers in this region may experience latency or brief connectivity interruptions. Our teams are closely monitoring the situation and will share updates as they become available.
Posted Oct 20, 2025 - 07:00 UTC