Redis - Service Status

Impact to Resource Creation and Scaling Operations

Incident Report for Redis

Resolved

The DNS-related issue affecting resource creation and scaling in Redis Cloud has been resolved. All functionality has been restored for Pro and Essentials customers, and systems are operating normally.
Posted Sep 18, 2025 - 21:29 UTC

Update

We have deployed a fix that resolves the issue for both Redis Cloud Pro and Essentials customers. Creation and scaling operations should now function as expected across all account types. If you are an Essentials customer and continue to experience connectivity issues when accessing your database, please contact our support team for assistance.

We continue to work with our third-party DNS provider on a full resolution and will share further updates as they become available.
Posted Sep 17, 2025 - 04:48 UTC

Monitoring

We have deployed a fix which has restored service for Redis Cloud Pro customers. Creation and scaling operations should now function as expected for those accounts. Redis Cloud Essentials customers may still experience issues when creating or scaling resources. We continue to work with our third-party DNS provider on a full resolution and will share further updates as they become available.
If you have any questions, please contact our support team.
Posted Sep 16, 2025 - 23:52 UTC

Update

We’re continuing to work with our third-party DNS provider to mitigate the ongoing issue. If you have any questions, please contact our support team.
Posted Sep 16, 2025 - 18:03 UTC

Investigating

We have identified an issue with a third-party DNS provider which may result in some customers experiencing failures creating new resources, including subscriptions and databases, as well as performing scaling operations in Redis Cloud. We are working with our partner to resolve this issue and will provide an update shortly.
Posted Sep 16, 2025 - 16:52 UTC
This incident affected: DNS Resolvers.